Kraken trading unavailable on cryptowat.ch
Incident Report for Cryptowatch
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 25, 2019 - 18:00 UTC
Investigating
We are currently investigating this issue.
Posted 4 months ago. Apr 25, 2019 - 05:00 UTC
This incident affected: Trading (Kraken).