Degraded service in Europe
Incident Report for Cryptowatch
Resolved
This incident has been resolved.
Posted Nov 16, 2022 - 15:10 UTC
Investigating
We are aware of users in some parts of Europe experiencing slow loading times on our website and Desktop.
Posted Nov 03, 2022 - 14:32 UTC
This incident affected: Market Data (Kraken, Binance, Zonda, Bitfinex, bitFlyer, Bithumb, BitMEX, Bitsquare, Bitstamp, Bittrex, BitVC, Bit-Z, BTC China, CEX.io, Coinbase Pro, Coinone, CryptoFacilities, Gate.io, Gemini, HitBTC, Huobi, Luno, OKCoin, OKEx, Poloniex, Qryptos, Quoine, Vault of Satoshi, WEX).