Network issues causing slow page load time
Incident Report for Cryptowatch
Resolved
This incident has been resolved.
Posted Oct 24, 2019 - 04:08 UTC
Monitoring
Load times are stable again. We're monitoring to make sure they remain stable.
Posted Oct 24, 2019 - 03:34 UTC
Investigating
We are currently investigating this issue.
Posted Oct 24, 2019 - 03:25 UTC