Trading performance degraded/unavailable
Incident Report for Cryptowatch
Resolved
This incident has been resolved.
Posted May 11, 2022 - 20:23 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 11, 2022 - 17:23 UTC
Investigating
We are currently investigating an issue with the trading platform experiencing degraded performance.
Posted May 11, 2022 - 13:43 UTC
This incident affected: Trading (Kraken, Binance, Bitfinex, Bitstamp, Coinbase Pro, Poloniex).